Опубликован новый Ruby 1.9.2

Разработчиками представлен новый релиз интерпретатора Ruby 1.9.2. Это самый свежий релиз серии 1.9.

Ruby 1.9.2 в основном совместим с 1.9.1, за исключением следующих изменений:

  • Много новых методов;
  • Новое API для сокетов (с поддержкой IPv6);
  • Новые кодировки;
  • Класс Random (генераторы случайных чисел);
  • Переработан класс Time. Решена проблема 2038 года;
  • Некоторые улучшения в regexp;
  • $: больше не содержит текущую директорию;
  • dl переработан над libffi;
  • Новая библиотека psych, являющаяся оболочкой для libyaml. Можно использовать вместо syck.

Подробнее можно прочитать на официальном сайте в разделах NEWS и ChangeLog.

Ruby 1.9.2 прошёл более 99% RubySpec.

Вам также может помочь