PHP 5.4.8 и PHP 5.3.18 доступны для загрузки

Группа разработки PHP представляет обновления: PHP 5.4.8 и PHP 5.3.18. Исправлено более 20 ошибок. Если на хостинге используется свой интерпретатор: обновляйте до 5.3.18, а лучше до PHP 5.4.8.

Это не значительное обновление интерпретатора PHP, однако, если вы полностью контролируете код своих скриптов стоит обновить версию.

Перечислим только ключевые исправления в этих релизах:

  • Исправлена ошибка #63111 (is_callable() возвращала неверный ответ для метода abstract static);
  • Исправлена ошибка #61442 (не перехватывалось исключение в __autoload). 

Исходники, как и всегда, на странице загрузки. Подробнее лучше прочитать на PHP.NET.

Вам также может помочь